Back to overview
Degraded
Intermittent delays and incomplete results in contact enrichments
Apr 15, 2026 at 8:50pm UTC
Affected services
Application and Extension
API
Resolved
Apr 16, 2026 at 1:30pm UTC
The issue has been resolved, and all services are now operating normally. We are continuing to monitor the system to ensure stability.
Affected services
Created
Apr 15, 2026 at 8:50pm UTC
We are currently experiencing issues with the enrichment feature that may cause slower processing times than usual. In some cases, enrichment requests may take significantly longer to complete or may not return results at all.
Our team is actively investigating the root cause and working to restore normal performance as quickly as possible. We will provide updates as more information becomes available.
Affected services