Back to overview
Degraded
Instability due to CloudFlare outage
Nov 18 at 01:34pm CET
Affected services
Application and Extension
API
Resolved
Nov 18 at 10:48pm CET
CloudFlare is no longer down
Affected services
Created
Nov 18 at 01:34pm CET
While Surfe is working some of the functionalities might be impacted.
Affected services