Back to overview
Degraded

Application and Extension and API are down

May 26, 2025 at 2:03pm UTC
Affected services
Application and Extension
API

Resolved
May 26, 2025 at 2:22pm UTC

Application and Extension recovered.

Updated
May 26, 2025 at 2:10pm UTC

API recovered.

Created
May 26, 2025 at 2:03pm UTC

API and Extension issues.