Back to overview
Resolved
Enrichment features were degraded
Sep 7, 2026 at 4:35pm UTC
Affected services
Application and Extension
API
MCP
Resolved
Sep 7, 2026 at 5:50pm UTC
Our engineers identified the root cause and pushed a fix.
Services are back to normal.
Affected services
Created
Sep 7, 2026 at 4:35pm UTC
Our enrichment features were degraded during this period; our engineers are investigating.
Affected services